无法安装吵闹鬼宝石 - Unable to install poltergeist gem

- 此内容更新于:2016-02-01
主题:

  我无法安装在windows7上吵闹鬼宝石我得到以下错误:
  暂时提高路径包括DevKit……
  建立本地扩展。这可能需要一段时间……
  错误:错误安装吵闹鬼:
  错误:无法建立宝石本地扩展。
  
  当前目录:C:/Ruby22-x64/lib/ruby/珠宝/2.2.0/珠宝/websocket-driver-0.6.3/ext/websocket-driver
  C:/rubyRuby22-x64/bin/。exe-r。/siteconf20160131-10856-19288-r4。rbextconf.rb
  创建Makefile
  
  当前目录:C:/Ruby22-x64/lib/ruby/珠宝/2.2.0/珠宝/websocket-driver-0.6.3/ext/websocket-driver
  让“DESTDIR="清洁
  “让”是不被认为是内部或外部命令,
  可操作的程序或批处理文件。
  
  当前目录:C:/Ruby22-x64/lib/ruby/珠宝/2.2.0/珠宝/websocket-driver-0.6.3/ext/websocket-driver
  让“DESTDIR=”
  “让”是不被认为是内部或外部命令,
  可操作的程序或批处理文件。
  
  使失败,退出代码1
  
  Gem文件仍将安装在C:/Ruby22-x64/lib/ruby/珠宝/2.2.0/珠宝/websocket-driver-0.6.3进行检查。
  结果记录到C:/Ruby22-x64/lib/ruby/珠宝/2.2.0/扩展/x64-mingw32/2.2.0/websocket-driver-0.6.3/gem_make.out
  我的ruby版本2.2.3p173和rubygems版本是2.5.1任何帮助将会非常感激

原文:

I am unable to install the poltergeist gem on windows 7 I keep getting the following error:

Temporarily enhancing PATH to include DevKit...
Building native extensions.  This could take a while...
ERROR:  Error installing poltergeist:
        ERROR: Failed to build gem native extension.

    current directory: C:/Ruby22-x64/lib/ruby/gems/2.2.0/gems/websocket-driver-0.6.3/ext/websocket-driver
C:/Ruby22-x64/bin/ruby.exe -r ./siteconf20160131-10856-19288r4.rb extconf.rb
creating Makefile

current directory: C:/Ruby22-x64/lib/ruby/gems/2.2.0/gems/websocket-driver-0.6.3/ext/websocket-driver
make "DESTDIR=" clean
'make' is not recognized as an internal or external command,
operable program or batch file.

current directory: C:/Ruby22-x64/lib/ruby/gems/2.2.0/gems/websocket-driver-0.6.3/ext/websocket-driver
make "DESTDIR="
'make' is not recognized as an internal or external command,
operable program or batch file.

make failed, exit code 1

Gem files will remain installed in C:/Ruby22-x64/lib/ruby/gems/2.2.0/gems/websocket-driver-0.6.3 for inspection.
Results logged to C:/Ruby22-x64/lib/ruby/gems/2.2.0/extensions/x64-mingw32/2.2.0/websocket-driver-0.6.3/gem_make.out

my ruby version is 2.2.3p173 and my rubygems version is 2.5.1

any help would be really appreciated

网友:这可能会帮助:stackoverflow.com/questions/19176136/?

(原文:This might help: stackoverflow.com/questions/19176136/…)