语言水平是ruby2.2.3锁定在Rubymine1.8 - The language level is locked at 1.8 on Rubymine for ruby 2.2.3

- 此内容更新于:2016-02-02
主题:

安装后,仍有语言水平锁定(不开放选择)导致调试gem安装错误。很少有文章报道类似的问题,没有一个人给出一个明确的答案(人提议升级rubymine5.46)。如何使语言水平符合ruby版本吗?

原文:

After installing ruby 2.2.3, the rubymine 6.0.1 still has language level locked at 1.8 (not open for choose) causing error in debug gem installation. There are few posts reporting the similar issue and none of them gives a clear answer (one is suggesting upgrading rubymine from 5.4 to 6). How to make the language level compatible with ruby version?

enter image description here

网友:为什么是6.0?RubyMine的最新版本是8.0!有什么特别的原因?

(原文:Why 6.0? Latest RubyMine version is 8.0! Is there any particular reason?)

楼主:这就是我们。根据一篇文章,rubymine6/7/8都有类似的问题。

(原文:That's what we are having. According to a post, rubymine 6/7/8 are all having the similar issue.)